Tltools "applicazione di win32 non valida"

Paolo Silvestri

Time-Lapser Novizio
#1
Salve a tutti, sono nuovo nel forum e cercavo aiuto per poter risolvere un problema.
Utilizzo Cyberlink Photodirector per la post delle mie foto, e da poco ho scoperto Tltools per il deflickering e altre utilissime opzioni: il problema è che dopo aver montato ed effettuato il rendering del video con le foto selezionate (jpg), a fine lavoro mi compare tale finestra che recita testualmente "1 non è un'applicazione di win32 valida". Ho spulciato su altri forum per lo stesso errore, ma la causa dovrebbe essere un worm che impedisce la sola installazione dei programmi, e non il corretto funzionamento. Cosa fare dunque?
Grazie a tutti in anticipo.
P.S. la finestra che si apre subito dopo il rendering cita "create process failed with error"
 
Ultima modifica:

Mamo

Donatore generoso
#2
Ciao Paolo,
Per il montaggio del video, il programma utilizza un prodotto esterno (ffmpeg) che dovrebbe essere stato installato durante l'installazione del pacchetto.
In basso a sinistra ci sono delle indicazioni per verificare la presenza di questi prodotti.
Se lo sfondo dei nomi dei programmi esterni è verde, vuol dire che il programma è stato trovato, altrimenti se è rosso, per qualche motivo l'installazione non è stata eseguita in modo corretto.
Puoi verificare la presenza di tale prodotto anche manualmente. Dovrebbe essere presente in C:\ (directory principale)
Se è presente, prova a fare un doppio click e vedere se ti da lo stesso problema.
Altra possibilità:
Hai installato qualche antivirus?
Il lancio di programmi esterni è un'operazione che viene spesso utilizzata dai virus, ma anche da programmi legittimi. Può essere che il tuo antivirus, blocchi queste operazioni. Da qui l'impossibilità del mio programma a lanciare programmi esterni.
 

Paolo Silvestri

Time-Lapser Novizio
#3
Ciao Paolo,
Per il montaggio del video, il programma utilizza un prodotto esterno (ffmpeg) che dovrebbe essere stato installato durante l'installazione del pacchetto.
In basso a sinistra ci sono delle indicazioni per verificare la presenza di questi prodotti.
Se lo sfondo dei nomi dei programmi esterni è verde, vuol dire che il programma è stato trovato, altrimenti se è rosso, per qualche motivo l'installazione non è stata eseguita in modo corretto.
Puoi verificare la presenza di tale prodotto anche manualmente. Dovrebbe essere presente in C:\ (directory principale)
Se è presente, prova a fare un doppio click e vedere se ti da lo stesso problema.
Altra possibilità:
Hai installato qualche antivirus?
Il lancio di programmi esterni è un'operazione che viene spesso utilizzata dai virus, ma anche da programmi legittimi. Può essere che il tuo antivirus, blocchi queste operazioni. Da qui l'impossibilità del mio programma a lanciare programmi esterni.
Le "estensioni" ExifTool, DCRaw e ffmpeg ci sono e sono su sfondo verde. Ho provato ad aprire ffmpeg tramite doppio click ma si apre solamente una finestra stile prompt dei comandi per chiudersi subito dopo. Per quanto riguarda la compatibilità ho già aggiunto il programma alla lista delle eccezioni consentite sia per il firewall che per Windows Defender, per l'antivirus non so se convenga momentaneamente disattivarlo. Non so se Windows 10 come sistema operativo rappresenti un problema.
 

Mamo

Donatore generoso
#4
Ok, vedo che ci smanetti un po'.
Senza disabilitare l'antivirus, prova a lanciare TLTools come amministratore (così vediamo se è una questione di permessi).
 

Mamo

Donatore generoso
#6
Per caso, nel tuo pc, è presente la cartella c:\ffmpeg ? (cioè esiste sia c:\ffmpeg.exe che c:\ffmpeg)
 

Mamo

Donatore generoso
#8
No, c'è solo l'exe. Adesso guardando meglio mi sono accorto che ExifTool ha un'icona definita mentre ffmpeg e DCRaw no.
Per le icone, è corretto che sia così. Sono due tool a riga di comando e non hanno un'interfaccia gui.
Solo per capire se il problema è del programma ffmpeg oppure è nel mio (cioè che non riesce a lanciare programmi esterni), puoi provare a far lanciare uno degli altri due tool presenti.
Puoi provare a lanciare exiftool selezionando una directory contenente dei file raw. (sono sufficienti un paio di raw, Se non ne hai a disposizione puoi fare una ricerca con google e cercare file nef o cr2. Anche se sono foto diverse, va bene lo stesso per la prova).
Puoi provare a lanciare dcraw ma in pratica devi avere comunque a disposizione delle immagini raw
http://www.tltools.it/wp/ManualeITA...ZGNyYXc=&ms=BQAQEA==&mw=MjQx&st=Mg==&sct=MA==
 

Paolo Silvestri

Time-Lapser Novizio
#9
Allora, ho aperto un file nef (scatto con nikon) sia con DCRaw che ExifTool. Con il primo si apre il prompt vuoto, con Exif invece mi crea istantaneamente un file contenente le info del raw, molto più grande della foto (36 mega contro 16 della foto). P.S. ho provato anche a montare un timelapse con dei file jpeg, stesso problema.
Solo ora mi sono ricordato, ho provato con i file jpeg perchè con i raw il programma mi chiude subito l'importazione per errore nei metadati e mancanza dei file XMP.
 
Ultima modifica:

Mamo

Donatore generoso
#10
In teoria con Exiftool dovrebbe crearti un file con estensione exif di dimensioni molto piccole (1 KB)
Lo trovi nella directory segnalata in basso al centro su sfondo verde ...documents\ciemmesoft\tltools\preview...
E' DCRaw che ti crea un file più grande della foto NEF. Questo perchè il file creato è un file bitmap a 24 bit NON compresso
Comunque, visto che questi due programmi funzionano e il metodo di lancio del programma esterno è il medesimo, credo che il problema sia nel programma ffmpeg.
Durante la creazione (o il tentativo) del video, il programma scrive un file log.
Lo trovi nella sottocartella
..documents\ciemmesoft\tltools\preview...\video e si chiama log.txt
Prova a vedere cosa ti dice.
All'interno di questo file log c'è il comando usato per lanciare ffmpeg (una cosa del genere)
c:\ffmpeg.exe -y -r 25 -i Frames\Frame_%04d.jpg -vcodec prores -profile:v 2 -qscale:v 11 -vendor ap10 -pix_fmt yuv422p10le "C:\Users\MAMO\Documents\Ciemmesoft\TLTools\_Preview00055\Video\Video_2018_05_12_20_49_58.mov"

Prova a copiarlo e lanciarlo da un prompt del dos
 

chi siamo

Time Lapse Italia è la community italiana dedicata alla fotografia time-lapse.

Impara la tecnica, condividi le tue esperienze e migliorati guardando i video più belli... gratuitamente ed in italiano!

© 2013-18 Time Lapse Italia - Creato da Marco Famà

invia il tuo video

Segui BENE tutte le istruzioni disponibili in questo breve tutorial e raggiungi la home-page di Time Lapse Italia
Alto